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System Administration of eProof

1. Introduction

This document should help you in configuring server and/or client OS for eProof using and describe
common issues that may prevent eProof from working properly.

2. Solving Firewall Issues

eProof is a complex web distributed client-server application, its functionality depends on properties
of external (WAN) and internal (LAN) networks. In most cases eProof server and client are located in
different networks, thus communication is done through proxy (firewall). Proxy/firewall configuration
peculiarities result in eProof client failing to start.

2.1. Symptoms of proxy/firewall issue
2.1.1. Both .jar and .class java file types are banned.

User logs in, eProof tries to start loading Java components, but in some time user is redirected to
browser compatibility page with “Java is not enabled in your browser...” error.

0 ERROR: Java is not enabled on your browser or is not installed on your
computer

Internet Explorer 6.x for Windows XP{5P2)/2003 Server

1. Install Java plugin. As automatic download is blocked by secunty settings please downlosd
installer manually. After download is finished unpack the content of .zip archive and run the
installer.

Internet Explorer 6.x for Windows 98/NT/2000 /%P

1. For Windows ¥P, install Java plugin {(fownriosd), For Windows 98/NT/2000, enable MS 1%M in your
browser
Tools-=Internet Optians. . ->Security->Custom level . -sMicrosoft Vh-ZJava permissions->High
safety

User checks browser settings according to instructions on the browser compatibility page (see image
above), and they are correct.

In this case please see Java console (see chapter 2.4. for instructions). The following strings should
be present there if .jar and .class files are not allowed by your firewall/proxy:

java.lang.ClassNotFoundException: DVC JVM Probe.class
at sun.applet.AppletClassLoader.findClass (Unknown Source)
at java.lang.ClassLoader.loadClass (Unknown Source)
at sun.applet.AppletClassLoader.loadClass (Unknown Source)
at java.lang.ClassLoader.loadClass (Unknown Source)
at sun.applet.AppletClassLoader.loadCode (Unknown Source)
at sun.applet.AppletPanel.createApplet (Unknown Source)
at sun.plugin.AppletViewer.createApplet (Unknown Source)
at sun.applet.AppletPanel.runlLoader (Unknown Source)
at sun.applet.AppletPanel.run (Unknown Source)
at java.lang.Thread.run (Unknown Source)
Caused by: java.net.ConnectException: Connection timed out: connect
at java.net.PlainSocketImpl.socketConnect (Native Method)
at java.net.PlainSocketImpl.doConnect (Unknown Source)
at java.net.PlainSocketImpl.connectToAddress (Unknown Source)
at java.net.PlainSocketImpl.connect (Unknown Source)
at java.net.Socket.connect (Unknown Source)
at sun.net.NetworkClient.doConnect (Unknown Source)
at sun.net.www.http.HttpClient.openServer (Unknown Source)
at sun.net.www.http.HttpClient.openServer (Unknown Source)



at sun.net.www.http.HttpClient.<init> (Unknown Source)

at sun.net.www.http.HttpClient.New (Unknown Source)

at sun.net.www.http.HttpClient.New (Unknown Source)

at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient (Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.plainConnect (Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.connect (Unknown Source)

at sun.net.www.protocol.http.HttpURLConnection.getInputStream (Unknown Source)
at java.net.HttpURLConnection.getResponseCode (Unknown Source)

at sun.applet.AppletClassLoader.getBytes (Unknown Source)

at sun.applet.AppletClassLoader.access$100 (Unknown Source)

at sun.applet.AppletClassLoader$l.run (Unknown Source)

at java.security.AccessController.doPrivileged (Native Method)

2.1.2. .class files are allowed, though .jar or .cab are not.

User logs in, eProof tries to start loading Java components, though loading stops (see screenshot
below).

User checks browser settings according to instructions on the browser compatibility page, and they
are correct.

Please see Java console (see chapter 2.4. for instructions). The following strings should be present
there if .jar files are not allowed by your firewall/proxy:

java.io.IOException: Server returned HTTP response code: 502 for URL:
http://172.18.0.36/eproof4240/Applets/ePInstallerl441T.jar
at sun.net.www.protocol.http.HttpURLConnection.getInputStream (Unknown Source)
at sun.plugin.net.protocol.http.HttpUtils.followRedirects (Unknown Source)
at sun.plugin.cache.CachedJarLoader.isUpToDate (Unknown Source)
at sun.plugin.cache.CachedJarLoader.loadFromCache (Unknown Source)
at sun.plugin.cache.CachedJarLoader.load (Unknown Source)
at sun.plugin.cache.JarCache.get (Unknown Source)
at sun.plugin.net.protocol.jar.CachedJarURLConnection.connect (Unknown Source)
at sun.plugin.net.protocol.jar.CachedJarURLConnection.getJarFile (Unknown Source)
at sun.misc.URLClassPath$JarLoader.getJarFile (Unknown Source)
at sun.misc.URLClassPathS$SJarLoader.<init> (Unknown Source)
at sun.misc.URLClassPath$3.run (Unknown Source)
at java.security.AccessController.doPrivileged (Native Method)
at sun.misc.URLClassPath.getLoader (Unknown Source)
at sun.misc.URLClassPath.getLoader (Unknown Source)
at sun.misc.URLClassPath.getResource (Unknown Source)
at java.net.URLClassLoader$1l.run (Unknown Source)
at java.security.AccessController.doPrivileged (Native Method)
at java.net.URLClassLoader.findClass (Unknown Source)



at sun.applet.AppletClassLoader.findClass (Unknown Source)
at java.lang.ClassLoader.loadClass (Unknown Source)
at sun.applet.AppletClassLoader.loadClass (Unknown Source)
at java.lang.ClassLoader.loadClass (Unknown Source)
at sun.applet.AppletClassLoader.loadCode (Unknown Source)
at sun.applet.AppletPanel.createApplet (Unknown Source)
at sun.plugin.AppletViewer.createApplet (Unknown Source)
at sun.applet.AppletPanel.runlLoader (Unknown Source)
at sun.applet.AppletPanel.run (Unknown Source)
at java.lang.Thread.run (Unknown Source)
load: class com.cyansoft.utl.ePInstaller.ePInstaller not found.
java.lang.ClassNotFoundException: com.cyansoft.utl.ePInstaller.ePInstaller
at sun.applet.AppletClassLoader.findClass (Unknown Source)
at java.lang.ClassLoader.loadClass (Unknown Source)
at sun.applet.AppletClassLoader.loadClass (Unknown Source)
at java.lang.ClassLoader.loadClass (Unknown Source)
at sun.applet.AppletClassLoader.loadCode (Unknown Source)
at sun.applet.AppletPanel.createApplet (Unknown Source)
at sun.plugin.AppletViewer.createApplet (Unknown Source)
at sun.applet.AppletPanel.runlLoader (Unknown Source)
at sun.applet.AppletPanel.run (Unknown Source)
at java.lang.Thread.run (Unknown Source)
Caused by: java.io.IOException: open HTTP connection failed.
at sun.applet.AppletClassLoader.getBytes (Unknown Source)
at sun.applet.AppletClassLoader.access$100 (Unknown Source)
at sun.applet.AppletClassLoader$l.run (Unknown Source)
at java.security.AccessController.doPrivileged (Native Method)

2.2. Check standard communication

In case you suspect proxy/firewall prevents Java applets from being loaded, you can check this by
running a standard known applet.
We recommend to open this Java test page: http://java.com/en/download/help/testvm.xml

You should see the page like on the image below, with Java-man dancing animation. If you have
problem viewing the applet on this page, you will have problem running eProof client. Try to change
your LAN settings so that you have http://java.com/en/download/help/testvm.xml displayed correctly (see
2.3. Possible solutions).

Address @ http:f fiava, comfenidownload/helpftestyvm, xml

(( Welcome to java.com.

Brought to you by Sun Microsystems.

Ja\fa‘ Duke’sZone | Games | Mobile |  Desktop

Installation Instructions

Test your Java Virtual Machine {JvM)

Thiz article applies to:

= Platformi(s):
Solariz SPARC, Solaris x86, Red Hat Linux, SUSE Linuwx, Windows 95, Windows
WE, Windaws 2000 (SP4+), Windows ¥P (SP1 SP2), Windows 2003, JDS

= Browser(s)
Irternet Explorer 5.5, Internet Explorer 6.x, Metscape 4.7x, Netzcape 6.2x,
Metzcape 7, Mozilla 1.4+ Firefox

* IRE version(s):
b op 85 Je0 W i WS W SN s S ) O B

Test your JVM

zing an older version of Java technalogy. *f'ou can dawnload

 from Java,com:
You Java configuaion s

Yendor: Micrasaft Corp
Version: 114
OperangSystem Widows NT

05 version: 5.0




In case you see the animation properly, but eProof client does not load, you have specific problem
eProof team will try to solve. To help us, please, send us Java log (refer to chapter 2.4. for
instructions on this)

2.3. Possible solutions

2.3.1. Enable .class, .jar and .cab file types on your firewall/proxy

If you have content-type filtering rules in your firewall/proxy, change them to allow these file types.
2.3.2. Configure transparent proxy

In transparent proxy, client Web browsers are unaware of the proxy’s presence. They “suppose”
they are routed directly to servers on the Internet with no agent in between. For example, in MS ISA
Server 2000 this feature is configured by enabling HTTP Redirector Filter.

=) =0llx
Action  Wiew L] @ +
Tree | Mame | Description

= gmg Intemet Security and Acceleration Server [PROXY) ﬂ f‘/ DMS intrusion detection filker Intercepts and analyzes DMS traffic destined for the intern:
=& Manitoring ﬁ/ FTP éccess Filker Enables FTP protacaols [client and server)
1 Alerts ’f}'gj H. 323 Filker Microgoft H. 323 filker
1 Services ?‘/ HTTF Redirectar Filker Redirects requests from Fireseall and SecureNAT clients ta
1 e
+-_] Reportz
5 Computer General ] Dptignsl
=12 Access Policy
1 Site and Content Rules
1 Protocal Rules B i HT TP Redirector Filer
1 IP Packet Filkerz
+- [ Publishing
1 Bandwidih Rules
-4t Policy Elements
1 Schedules Wersian: an
1 Bandwidth Priarities o
1 Destination Sets Description:  |Redirects requests from Firewall and SecureNAT client
1 Client Address Sets
1 Protocol Definitions
1 Content Groups Fl | | ﬂ
1 Dialup Entries
B ﬁ Cache Configuration
1 Scheduled Content Download Jobs
1 Drives
+-[74) Manitaring Configuration
= & Extenzionz
— Application Filters I I Enable this filter
1 "eb Filkerz
B _J Metwork Configuration
1 Routing

] Local Address Table [LAT) 0k | Cancel

1 Local Domain Table (LOT] =] ’

Wendor: Microzoft

2.4. How to View Java Log

Find below instructions on how to get Java log with different operating systems and configurations.
2.4.1. Mac OS

OS X:

Before running eProof start Console, where log will be written.
Go to Application > Utilities > Console in Finder.



- s -—

B Tecters-x3 [ AppleScript w0 B A!:tivity Monllmr N a
7S i U Calculator » AirPort Admin Utility
@ Network 4 Chess -~ EI AirPort Setup Assistant
% Font Book | @ Asia Text Extras »
il €2 ichat ™ Audio MIDI Setup

i@ Image Capture <» Bluetooth File Exchange

€ Bluetooth Serial Utility

) Internet Connect ¢
kd Bluetooth ...p Assistant

£ Internet Explorer

I iTunes ¥ ColorSync Utility
. & Mail B Console
| W& Preview & DigitalColor Meter
| ) QuarkXPress 6.0 : 5 Directory Access
) QuickTime Player & Disk Utility
| @ Safari K Grab
& Sherlock 3 Installer
Stickies [ & Java ¢
| Stuffit Deluxe 7.0 | A Keychain Access

¢ System Preferences

"

I[_ _ Utilities 2 TextEdit

v’/ @ Netinfo Manager

& -

. @ Nework Urtility

[ uilities i & ODBC Administrator

4 |

After you replicate the issue in eProof and Java messages are written to console, please copy
Console content:

- select Java console content (you can use Edit > Select All command)

- copy selected text (use Edit > Copy command or Command+V keyboard shortcut)

- insert clipboard into a text document and save it.

0S 9.x

Before running eProof open Java console
Go to View > Java messages menu item.
Go Favorites Tools

:ol Button Bar

iv Address Bar

+ Favorites Bar

v Status Bar

v Explorer Bar 8T

4 Collapse Toolbars 3B
Customize Toolbars...
Browser Color m

Text Zoom
Character Set

Stop Loading 3.
Refresh #R
Load Images

v wv

Java Messages
Source #BE

After you replicate the issue in eProof, copy Java messages:
- select Java console content (you can use Edit > Select All command)
- copy selected text (use Edit > Copy command or Command+V keyboard shortcut)
- insert clipboard into a text document and save it.

Note: Java messages are written to the "Java message log" file in Internet Explorer folder. You can
send the file itself.

2.4.2. Windows OS

Microsoft Java Virtual Machine:
Java console is disabled by default. Enable it before getting Java logs:

- open Internet Options (Open browser window and select the Tools > Internet Options menu
item)
- switch to the Advanced tab in the Internet Options dialog



- check the Java console enabled and Java logging enabled checkboxes in Microsoft VM
section.

Internet Options il 5'

Generall Seu:urit_l,ll F'rivau:_l,ll I:u:untentl Eu:unneu:tiu:unsl Programsz Advanced

Settings:

{1 HTTP 1.1 settings -

Hze HTTP 1.1
O Use HTTF 1.1 through prosy connections
E} icrozoft Wk
Java conzole enabled [requires restart]
Java logging enabled
JIT compiler for wirtual machine enabled [requires restart)
8, Multimedia
O Don't display arline media content in the media bar
E nable Automatic Image Resizing
Enable Image Toolbar [requires restart]
Play animations in web pages
Play soundz in web pages
Play videos in web pages
O Show image download placeholders

Show pictures -
4| | »

Bestore Defaultz |

k. I Cancel | Spply |

- hit Ok and restart the browser

Open Java console select before starting eProof:

Go to View -> Java console menu item in browser window.
FruULl gallh fa0 — Ll.ll_.ll.lll = I"HLruUsLIL

E | Wiew Faworites  Tools

Toolbars
Status Bar
Explorer Bar

Go To
Skop
Refresh

Texkt Size
Encoding

Source
Privacy Report...
Full Screen

Java Console

After you have faced a problem in eProof, copy Java log:
- select the content of Java console by dragging the mouse
- Use CTRL+C keyboard shortcut to copy Java console content
- Insert clipboard content into a text document and save it.

Sun Java Plug-in:
Console is enabled by default and you don’t need to perform additional setup to get Java logs.

Open Java console

select menu item Tool > Sun Java > Console in your browser window



Tools  Help

Mail and Mews L
Synchronize. ..
Windows Update

Flashizet
Show Related Links

Sun Java Cansale

Internet Cplions., ..

Copy Java log and send it to support:
- open Java console
- select the content of Java console with CTRL+A shortcut
- Use CTRL+C keyboard shortcut or hit the Copy button to copy Java console content
- Insert clipboard content into a text document and save it.
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